import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:Miss|Mr|Lady|Mrs|Ms|Dr|Sir)\\b|Mr\\.)\\s+)?(\\S+)";
final String string = "Mrs Daksha Karsan\n"
+ "Mr Shane Kyle Taylor\n"
+ "Mr Ahmed Demerdash Keyani\n"
+ "Perry Joe Wilson\n"
+ "Miss Chantelle Reece\n"
+ "Mike Stewart\n"
+ "Dr Ariel Verun Patel\n"
+ "Mr John Sim\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}