re = /^(?:(?:(?:Miss|Mr|Lady|Mrs|Ms|Dr|Sir)\b|Mr\.)\s+)?(\S+)/m
str = 'Mrs Daksha Karsan
Mr Shane Kyle Taylor
Mr Ahmed Demerdash Keyani
Perry Joe Wilson
Miss Chantelle Reece
Mike Stewart
Dr Ariel Verun Patel
Mr John Sim
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result