using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?:Miss|Mr|Lady|Mrs|Ms|Dr|Sir)\b|Mr\.)\s+)?(\S+)";
string substitution = @"$1";
string input = @"Mrs Daksha Karsan
Mr Shane Kyle Taylor
Mr Ahmed Demerdash Keyani
Perry Joe Wilson
Miss Chantelle Reece
Mike Stewart
Dr Ariel Verun Patel
Mr John Sim
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}