import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *[0-9]+([.,][0-9]+)?(/[0-9]+([.,][0-9]+)?)? *";
final String string = "400 mg\n"
+ "50/12,5 mg/ml\n"
+ "20 mikrog\n"
+ "500 mg/400 IU\n"
+ "60 mikrog/15 mikrog";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}