$re = '~ *[0-9]+([.,][0-9]+)?(/[0-9]+([.,][0-9]+)?)? *~m';
$str = '400 mg
50/12,5 mg/ml
20 mikrog
500 mg/400 IU
60 mikrog/15 mikrog';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;