using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(STRING.*?)\)";
string substitution = @"$1]";
string input = @"foo)bar)baz STRING foo)bar";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}