import re
regex = re.compile(r"(STRING.*?)\)", flags=re.MULTILINE)
test_str = "foo)bar)baz STRING foo)bar"
subst = "$1]"
result = regex.sub(subst, test_str)
if result:
print(result)