import Foundation
let pattern = #"(STRING.*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"foo)bar)baz STRING foo)bar"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)