package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(STRING.*?)\)`)
var str = `foo)bar)baz STRING foo)bar`
var substitution = "$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}