re = /(STRING.*?)\)/m
str = 'foo)bar)baz STRING foo)bar'
subst = '$1]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result