use strict;
my $str = 'foo)bar)baz STRING foo)bar';
my $regex = qr/(STRING.*?)\)/mp;
my $subst = '$1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";