$re = '/(STRING.*?)\)/m';
$str = 'foo)bar)baz STRING foo)bar';
$subst = "$1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;