# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))/$1 /g;t' <<< "Inverted HFFSfor Primary Wrap Or Secondary Multi Wrap
HFFSwith PDSPbackgroud Feederlense & Product Alignerigit
HFFSwith Cooler JKLHbetween Feeder & Product Aligner"