re = /\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))/
str = 'Inverted HFFSfor Primary Wrap Or Secondary Multi Wrap
HFFSwith PDSPbackgroud Feederlense & Product Alignerigit
HFFSwith Cooler JKLHbetween Feeder & Product Aligner'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result