import Foundation
let pattern = #"\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Inverted HFFSfor Primary Wrap Or Secondary Multi Wrap
HFFSwith PDSPbackgroud Feederlense & Product Alignerigit
HFFSwith Cooler JKLHbetween Feeder & Product Aligner
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)