const regex = /\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))', 'g')
const str = `Inverted HFFSfor Primary Wrap Or Secondary Multi Wrap
HFFSwith PDSPbackgroud Feederlense & Product Alignerigit
HFFSwith Cooler JKLHbetween Feeder & Product Aligner`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);