import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))";
final String string = "Inverted HFFSfor Primary Wrap Or Secondary Multi Wrap\n"
+ "HFFSwith PDSPbackgroud Feederlense & Product Alignerigit\n"
+ "HFFSwith Cooler JKLHbetween Feeder & Product Aligner";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}