import re
regex = re.compile(r"\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))")
test_str = ("Inverted HFFSfor Primary Wrap Or Secondary Multi Wrap\n"
"HFFSwith PDSPbackgroud Feederlense & Product Alignerigit\n"
"HFFSwith Cooler JKLHbetween Feeder & Product Aligner")
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)