#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$"
Local $sString = "Мама" & @CRLF & _
"ПетР" & @CRLF & _
"авТо" & @CRLF & _
"песня" & @CRLF & _
"гриБ" & @CRLF & _
"Яблоко" & @CRLF & _
"яБлоко" & @CRLF & _
"ябЛоко" & @CRLF & _
"яблОко" & @CRLF & _
"яблоКо" & @CRLF & _
"яблокО" & @CRLF & _
"Три богатыря" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")