using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$";
string input = @"Мама
ПетР
авТо
песня
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
Три богатыря
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}