$re = '/^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$/m';
$str = 'Мама
ПетР
авТо
песня
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
Три богатыря
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);