re = /^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$/m
str = 'Мама
ПетР
авТо
песня
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
Три богатыря
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end