import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$";
final String string = "Мама\n"
+ "ПетР\n"
+ "авТо\n"
+ "песня\n"
+ "гриБ\n"
+ "Яблоко\n"
+ "яБлоко\n"
+ "ябЛоко\n"
+ "яблОко\n"
+ "яблоКо\n"
+ "яблокО\n"
+ "Три богатыря\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}