const regex = new RegExp('^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$', 'gm')
const str = `Мама
ПетР
авТо
песня
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
Три богатыря
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}