import re
regex = re.compile(r"^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$", flags=re.MULTILINE)
test_str = ("Мама\n"
"ПетР\n"
"авТо\n"
"песня\n"
"гриБ\n"
"Яблоко\n"
"яБлоко\n"
"ябЛоко\n"
"яблОко\n"
"яблоКо\n"
"яблокО\n"
"Три богатыря\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")