#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\d]{4})[- ](0?[1-9]|1[0-2])[- ](\d{1,4})\b"
Local $sString = "Payment of invoice nr.2021-02-9999" & @CRLF & _
"Invoice 2021 3 27 has been paid" & @CRLF & _
"My invoice 21-3-27 Testing, should not work." & @CRLF & _
"My other invoice 2021-13-27 and 2021-0-27, should not work." & @CRLF & _
"My invoice 2021-1-27 and 2021-01-1234 , should both work" & @CRLF & _
"Invoice 2021 3 19999 has been paid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")