using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d]{4})[- ](0?[1-9]|1[0-2])[- ](\d{1,4})\b";
string input = @"Payment of invoice nr.2021-02-9999
Invoice 2021 3 27 has been paid
My invoice 21-3-27 Testing, should not work.
My other invoice 2021-13-27 and 2021-0-27, should not work.
My invoice 2021-1-27 and 2021-01-1234 , should both work
Invoice 2021 3 19999 has been paid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}