use strict;
my $str = 'Payment of invoice nr.2021-02-9999
Invoice 2021 3 27 has been paid
My invoice 21-3-27 Testing, should not work.
My other invoice 2021-13-27 and 2021-0-27, should not work.
My invoice 2021-1-27 and 2021-01-1234 , should both work
Invoice 2021 3 19999 has been paid';
my $regex = qr/([\d]{4})[- ](0?[1-9]|1[0-2])[- ](\d{1,4})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}