$re = '/([\d]{4})[- ](0?[1-9]|1[0-2])[- ](\d{1,4})\b/m';
$str = 'Payment of invoice nr.2021-02-9999
Invoice 2021 3 27 has been paid
My invoice 21-3-27 Testing, should not work.
My other invoice 2021-13-27 and 2021-0-27, should not work.
My invoice 2021-1-27 and 2021-01-1234 , should both work
Invoice 2021 3 19999 has been paid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);