// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\d]{4})[- ](0?[1-9]|1[0-2])[- ](\d{1,4})\b").unwrap();
let string = "Payment of invoice nr.2021-02-9999
Invoice 2021 3 27 has been paid
My invoice 21-3-27 Testing, should not work.
My other invoice 2021-13-27 and 2021-0-27, should not work.
My invoice 2021-1-27 and 2021-01-1234 , should both work
Invoice 2021 3 19999 has been paid";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}