import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d]{4})[- ](0?[1-9]|1[0-2])[- ](\\d{1,4})\\b";
final String string = "Payment of invoice nr.2021-02-9999\n"
+ "Invoice 2021 3 27 has been paid\n"
+ "My invoice 21-3-27 Testing, should not work.\n"
+ "My other invoice 2021-13-27 and 2021-0-27, should not work.\n"
+ "My invoice 2021-1-27 and 2021-01-1234 , should both work\n"
+ "Invoice 2021 3 19999 has been paid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}