const regex = /([\d]{4})[- ](0?[1-9]|1[0-2])[- ](\d{1,4})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d]{4})[- ](0?[1-9]|1[0-2])[- ](\\d{1,4})\\b', 'gm')
const str = `Payment of invoice nr.2021-02-9999
Invoice 2021 3 27 has been paid
My invoice 21-3-27 Testing, should not work.
My other invoice 2021-13-27 and 2021-0-27, should not work.
My invoice 2021-1-27 and 2021-01-1234 , should both work
Invoice 2021 3 19999 has been paid`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}