import re
regex = re.compile(r"([\d]{4})[- ](0?[1-9]|1[0-2])[- ](\d{1,4})\b", flags=re.MULTILINE)
test_str = ("Payment of invoice nr.2021-02-9999\n"
"Invoice 2021 3 27 has been paid\n"
"My invoice 21-3-27 Testing, should not work.\n"
"My other invoice 2021-13-27 and 2021-0-27, should not work.\n"
"My invoice 2021-1-27 and 2021-01-1234 , should both work\n"
"Invoice 2021 3 19999 has been paid")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")