package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((([^ ]+) +(me debe) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))`)
var str = `Anota que le debo 3€ a Antonio
Anota que le debo 3€ a Antonio del Monster
Anota que le debo 3€ del Monster a Antonio
Anota que @EsclavoDeLaLuna me debe 6 euros del monster`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}