import Foundation
let pattern = #"((([^ ]+) +(me debe) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Anota que le debo 3€ a Antonio
Anota que le debo 3€ a Antonio del Monster
Anota que le debo 3€ del Monster a Antonio
Anota que @EsclavoDeLaLuna me debe 6 euros del monster
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)