import re
regex = re.compile(r"((([^ ]+) +(me debe) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))")
test_str = ("Anota que le debo 3€ a Antonio \n"
"Anota que le debo 3€ a Antonio del Monster\n"
"Anota que le debo 3€ del Monster a Antonio \n"
"Anota que @EsclavoDeLaLuna me debe 6 euros del monster")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")