import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([^ ]+) +(me debe) +(\\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))";
final String string = "Anota que le debo 3€ a Antonio \n"
+ "Anota que le debo 3€ a Antonio del Monster\n"
+ "Anota que le debo 3€ del Monster a Antonio \n"
+ "Anota que @EsclavoDeLaLuna me debe 6 euros del monster";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}