// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((([^ ]+) +(me debe) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))").unwrap();
let string = "Anota que le debo 3€ a Antonio
Anota que le debo 3€ a Antonio del Monster
Anota que le debo 3€ del Monster a Antonio
Anota que @EsclavoDeLaLuna me debe 6 euros del monster";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}