use strict;
my $str = 'Anota que le debo 3€ a Antonio
Anota que le debo 3€ a Antonio del Monster
Anota que le debo 3€ del Monster a Antonio
Anota que @EsclavoDeLaLuna me debe 6 euros del monster';
my $regex = qr/((([^ ]+) +(me debe) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}