#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[[:space:]]|(?=(?![',])[[:punct:]])"
Local $sString = "I'm not that good at regex yet, but am getting better!"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)