$re = '/[[:space:]]|(?=(?![\',])[[:punct:]])/';
$str = 'I\'m not that good at regex yet, but am getting better!';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;