import re
regex = re.compile(r"[[:space:]]|(?=(?![',])[[:punct:]])")
test_str = "I'm not that good at regex yet, but am getting better!"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)