import Foundation
let pattern = #"[[:space:]]|(?=(?![',])[[:punct:]])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I'm not that good at regex yet, but am getting better!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)