re = /[[:space:]]|(?=(?![',])[[:punct:]])/
str = 'I\'m not that good at regex yet, but am getting better!'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result