# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*/$1 $2/;t' <<< "cast (mara.attyp as prodcategory preserving type ) as ProductCategory"