import Foundation
let pattern = #"(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"cast (mara.attyp as prodcategory preserving type ) as ProductCategory"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}