import re
regex = re.compile(r"(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*")
test_str = "cast (mara.attyp as prodcategory preserving type ) as ProductCategory"
subst = "$1 $2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)