// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*").unwrap();
let string = "cast (mara.attyp as prodcategory preserving type ) as ProductCategory";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}