use strict;
my $str = 'cast (mara.attyp as prodcategory preserving type ) as ProductCategory';
my $regex = qr/(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*/p;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";