package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*`)
var str = []byte(`cast (mara.attyp as prodcategory preserving type ) as ProductCategory`)
var substitution = []byte("$1 $2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}